Ein Blog rund um Microsoft Windows und allem, was sonst noch so anfällt...

Outlook und Explorer PDF Preview auf 64 Bit

von Georg Binder 16. September 2009 09:04

Dass der Adobe PDF Preview Handler unter 64 Bit Vista/Windows 7 nicht richtig funktioniert – und damit weder im Windows Explorer noch in Outlook das PDF Dokument vorab anzeigt -ist altbekannt und schon oft (auch auf WindowsBlog z.B.  hier oder hier) diskutiert:

image

Die bisherige Lösung zumindest für Outlook hat geheißen: Foxit Preview Handler installieren. Doch nun hat mir MarkusR einen super Hinweis geschickt. Und einen ziemlich arg peinlichen für Adobe. Dass der Handler nicht funktioniert dürfte schlicht auf den Umstand zurückzuführen sein, dass Adobe einen Registry Key nicht richtig setzt?!

Der manuelle Weg:

  • Gehe zu HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{DC6EFB56-9CFA-464D-8880-44885D7DC193}
  • Ändere den existierenden Wert AppID, der falsch auf {6d2b5079-2f0b-48dd-ab7f-97cec514d30b} gesetzt ist, in {534A1E02-D58F-44f0-B58B-36CBED287C7C}

Und schon geht’s (in meinem Fall mit Windows 7 64 Bit RTM und Office 2010 32 Bit Technical Preview):

image

Sensationell. Adobe ist das Problem seit fast 3 Jahren bekannt, ich kann mir eigentlich nicht vorstellen, dass da keine Absicht dahintersteht? Übrigens - eine Lästigkeit bleibt: nach einem Update des Adobe Readers kann sein, dass der Wert wieder falsch gesetzt ist,… Adobe wird hiermit verdonnert, 100x den Artikel auf MSDN abzuschreiben, wie man denn richtig einen Preview Handler installiert,…

Ein fertiges Reg File, die Quelle und noch mehr Information gibts unter:
http://www.pretentiousname.com/adobe_pdf_x64_fix/index.html

Danke an Markus für den Tipp!

 

Comments (36) -

>

9/16/2009 9:55:41 AM#

Verschwörung!

Alexander | Reply

>
>

9/16/2009 9:59:34 AM#

Hab ich mir auch gedacht. Was halt dagegen spricht: warum sollten sie das absichtlich machen, da wär mir jetzt nicht wirklich ein Grund eingefallen.

Georg BinderAustria | Reply

>
>
>

9/16/2009 1:21:41 PM#

grund wüsste ich auch keinen, aber ich kann mir nicht vorstellen das adobe diesen "fehler" übersehen hat jahrelang ...

hab auf deinen tipp hin auch foxit verwendet, nutze aber jetzt dank dir auch den adobe reader für die preview. zum glück kommen ja nicht zu oft reader updates, somit sollte der wert ja nicht all zu oft verändert werden müssen.

auf jeden fall danke! diesen artikel druck ich gleich als .XPS und dann kommt er in meine tipp sammlung ;)

MarcusAustria | Reply

>

9/16/2009 11:07:15 AM#

funktioniert auch unter Vista Ultimate 64bit und Office 2007SP2...

GuruAustria | Reply

>

9/16/2009 11:32:18 AM#

Funktioniert einwandfrei.
Wieder einen Doppelklick gespart - war zuvor nervig... Wink

Toni PohlAustria | Reply

>

9/16/2009 1:26:44 PM#

hm, also bei mir unter windows vista 64bit inkl. office 2007 funktioniert das nicht :/ weder manuell noch mit dem fertigen REG-Key. schreibt er mir nach wie vor das kein programm für die vorschau installiert ist :/ schade dachte ich könnte auf foxit verzichten.

MarcusAustria | Reply

>
>

9/16/2009 10:16:38 PM#

Schau noch mal auf die Seite, Leo D. hat sie aktualisiert um Informationen wenns nicht geht. Vielleicht hilft es ja.

Georg BinderAustria | Reply

>

9/16/2009 1:40:24 PM#

Und ich bin froh, wenn es nicht zu jeder Datei eine Preview gibt. "Immer Symbole statt Miniaturansichten anzeigen" ist daher bei mir aktiviert. Denn nicht nur, daß Miniaturansichten völlig unnötiger weise Ressourcen verschleudern, es hatte bei mir noch eine ganz andere Nebenwirkung auf einer externen Festplatte. Riesengroße Videodatei gelöscht > Explorer geschlossen > Explorer geöffnet > Videodatei war wieder da und ließ sich von da an nicht mehr unter Vista löschen. Dann unter XP angeschlossen > Datei ließ sich problemlos löschen und kam auch nicht wieder. Okay, Festplatte stundenlang getestet. Dateisystem in Ordnung, Sektoren in Ordnung, aus dem Gehäuse ausgebaut und SMART Werte ausgelesen; waren ebenfalls in Ordnung. Hab sogar die Zugriffsberechtigungen geprüft. Einfach kein Fehler, unter XP lief sie wie gehabt völlig problemlos und sobald sie an Vista hing und mehrere hundert MB bis mehrere GB große (Video)Dateien gelöscht wurden, waren so rund 2/3 von denen beim nächsten Öffnen im Explorer wieder da. In der Regel auch nicht abspielbar und auch nicht löschbar; daher lag mein Verdacht beim Dateisystem. Auf jeden Fall ein massives Fehlverhalten. Google brachte mich auch nicht weiter, höchstens ein Filtertreiberproblem eines Virenscanners kam laut Google in Frage, hätte bei mir auch gepaßt, aber mein Bauchgefühl stimmte nicht und sagte mir das ist nicht die Lösung. Daher hab ich weiter gesucht und irgendwann halt "Immer Symbole statt Miniaturansichten anzeigen" angehakt und seitdem ist das Problem gelöst. Testweise hatte ich nochmal die Miniaturansichten aktiviert gehabt > Problem trat wieder auf > Miniaturansichten wieder deaktiviert > Problem war wieder weg.

PS: Wofür braucht man eine Preview, wenn man aussagekräftige Dateinamen hat. Höchstens bei Fotos sinnvoll und da nehme ich zur Sichtung großer Fotosammlungen die IrfanView Thumbnail Funktion. Die ist nicht nur wesentlich schneller als die Kombi Miniaturansichten / extra große Symbole, sondern läßt sich auch noch viel, viel stärker auf die individuellen Anforderungen abstimmen.

wer im Glashaus sitzt...Germany | Reply

>
>

9/16/2009 4:21:22 PM#

Häää?!

beleAustria | Reply

>
>
>

9/16/2009 5:15:51 PM#

Du sagst es, das war eines der Probleme, die ich unter spooky verbucht habe. Ob und in wie weit da der Intel Matrix Storage Treiber auch noch in einer frühen Version eine Rolle gespielt haben könnte, weiß ich nicht. Der kommt mir nämlich auch reichlich komisch vor. Ich mag das Ding einfach nicht. Fest steht nur, daß es ein Problem gab, welches verschwunden ist, seitdem ich "Immer Symbole statt Miniaturansichten anzeigen" aktiviert habe.

wer im Glashaus sitzt...Germany | Reply

>
>
>
>

9/16/2009 5:20:11 PM#

Hey, der Kommentar war aber jetzt gleich da, oder? - danke fürs unfreiwillige mittesten Smile

Im übrigen glaube ich eher dass es sich um das bekannte 0-Byte Files Problem gehandelt hat, bzw. um das hier:
blogs.technet.com/.../3174194.aspx

Hat mit NTFS nichts zu tun, sondern mit der Datei-Virtualisierung.

Georg BinderAustria | Reply

>
>
>
>
>

9/16/2009 5:36:44 PM#

> Hey, der Kommentar war aber jetzt gleich da, oder?

Ja, ich meine das war er. Oder du hast ihn blitzschnell freigeschaltet.

> Im übrigen glaube ich eher dass es sich um das bekannte 0-Byte Files Problem gehandelt hat

Danke für den Link, lese ich mir gleich in Ruhe durch. Hab es nur kurz überflogen, könnte aber in der Tat Parallelen geben, wenn ich das hier lese:

Normally, the shell stores thumbnail cache files in your profile, but PMIE can’t write to that location so the shim virtualizes it:

Geht ja eindeutig in Richtung Miniaturansichten. Ich frage mich nur gerade warum der IE protected mode einer ganz normalen Explorer Operation dazwischenpfuschen muß, auch wenn der IE gar nicht in Benutzung ist. Mir ist zwar klar, daß IE und Explorer viel stärker miteinander verbundelt sind, als man erstmal glaubt, aber daß das auch für den protected mode gilt, war mir neu.

wer im Glashaus sitzt...Germany | Reply

>
>
>
>
>
>

9/16/2009 6:31:30 PM#

Darauf kann ich Dir zwar antworten, aber nur ungern,.. viele Teile von Windows sind ziemlich mit IE verheiratet,... bitte nicht nachfragen.

Georg BinderAustria | Reply

>
>
>
>
>
>
>

9/16/2009 10:45:36 PM#

He, he, das ist doch ein offenes Geheimnis, daß IE und Explorer ziemlich eng miteinander verbundelt sind und MS daher echte Probleme haben dürfte den IE tatsächlich aus dem System zu entfernen anstatt ihn nur unsichtbar zu machen, wenn sie es denn tatsächlich mal ernsthaft müßten.

Öffne mal unter XP den Arbeitsplatz und mach in der Statusleiste einen Doppelklick wo "Eigener Computer" steht (ggf. muß man die Statusleiste erst einblenden). Dann sieht man sofort wie der Hase läuft (sprich daß der Explorer dem Anschein nach mit dem Zonenmodell des IE arbeitet) Laughing Nur dachte ich halt, daß der Explorer eben nicht per default in der Zone "Internet" ausgeführt wird, weil in der ja meines Wissens nach als einzige der geschützte Modus (PMIE) per default aktiviert ist (neben der Zone "eingeschränkte Sites" natürlich, aber die macht beim Explorer ja gar keinen Sinn). Aber wenn ich jetzt eins und eins zusammenzähle, wird das wohl zu meiner Überraschung wohl möglicherweise doch so sein, daß der Explorer im Kontext der Zone "Internet" läuft und nicht wie ich bisher dachte in der Zone "vertrauenswürdige Sites".

wer im Glashaus sitzt...Germany | Reply

>

9/16/2009 1:49:55 PM#

Adobe ist meiner Meinung nach generell sehr schwach, wenn es um das Beheben von Fehlern geht, die schon jahrelang bekannt sind.
Bsp.:
Adobe Acrobat + Reader funktionieren ab Version 9.0 nicht mehr mit aktivierter GPO-Ordnerumleitung auf einen UNC-Pfad...
Bei uns in der Firma müssen wir deshalb noch immer die 8er-Versionen verwenden, obwohl 9er gekauft wurden.

SchaussiAustria | Reply

>
>

9/16/2009 5:12:55 PM#

Dann nimm die Version 9.1, da ist das Problem behoben.

MartinGermany | Reply

>
>
>

9/16/2009 5:55:57 PM#

Leider nicht... auch nicht mit aktuellsten Updates.

SchaussiAustria | Reply

>

9/16/2009 2:00:45 PM#

Vielen Dank Adobe Wink
Erst gestern Foxit iFilter installiert obwohl ich die Adobe Suite installiert habe ...

narfkSchweiz | Reply

>

9/16/2009 2:28:45 PM#

Vielleicht hat das den Adobe Leuten noch keiner verraten Wink

Die schaffen es ja auch nicht, dass man eine aktuelle Version runterladen kann. Es gibt nur Version 9 (mit Sicherheitslücken), die man danach tunlichst auf die aktuelle Version patchen sollte.

Auch kein Ruhmesblatt...

MarkusAustria | Reply

>
>

9/16/2009 4:10:46 PM#

Ja, ist eigenartig, vor allem auch, dass die Version zum Download - kaum installiert - schon wieder einem Update unterziehen muss.

MartinAustria | Reply

>

9/16/2009 4:24:33 PM#

Ich weiß nicht was du testest, aber bei meinem Kommentar vorhin war auch was komisch. Erst war es kurz da und nach einem Reload weg und kam dann erst Stunden später wieder. Allerdings ohne einen Hinweis, daß es auf eine moderative Freigabe warten würde, wie es die Tage zuvor zeitweise wegen des Spammers war. Außerdem spinnt zwischendurch immer mal die Anzeige der letzten 10 Kommentare und sie stimmt nicht immer mit dem RSS Feed der 10 letzten Kommentare überein. Außerdem stehen bei den 10 letzten Kommentaren öfters die "Georg Binder" Kommentare mit Absender "admin" drin, wenn man das Kommentar selber liest steht da aber "Georg Binder". Also alles etwas durcheinander mit der Blogsoftware.

wer im Glashaus sitzt...Germany | Reply

>
>

9/16/2009 4:30:37 PM#

Jup. Wir haben ein tolles Anti-Spam Ding drin, das ist auch bitter notwendig. Und meine Begeisterung hält sich momentan in Grenzen, weil es 100% der Kommentare als Spam erkennt.

Der Spammer ist nebenbei auch durchaus fleißig, ...

Ich hoffe, dass wir den Normalbetrieb (sprich, dass ein Kommentar sofort sichtbar ist, und nichtnach 10 Stunden) möglichst bald wieder hergestellt haben.

Aber hey, dafür geht Opera wieder ;)

Georg BinderAustria | Reply

>
>
>

9/16/2009 4:48:01 PM#

> Aber hey, dafür geht Opera wieder ;)

DAS ist eh überhaupt das wichtigste Laughing Denn Opera gehört zur Familie Wink

wer im Glashaus sitzt...Germany | Reply

>

9/16/2009 6:17:57 PM#

Vielen, vielen Dank für den Link. Smile Diese PDF Vorschau hat mich schon einiges an Nerven und Zeit gekostet...

Der WillyGermany | Reply

>

9/18/2009 7:09:15 PM#

Microsoft hätte mit Windows 7 endlich ganz auf 64 Bit umstellen sollen. Diese Zweigleisigkeit wegen irgendwelchen Firmen, deren alter Krempel womöglich unter 64 Bit nicht läuft, halte ich für einen Fehler. Denn wie lange will man den 32-Bit-Rucksack noch mitgeschleppen?
Dabei hieß es doch mal, der Vista-Nachfolger kommt nur mehr in 64 Bit. Nix ist draus geworden und ich verwette fast meinen Allerwertesten, dass sich das auch beim nächsten BS von Microsoft nicht ändern wird.

GMAustria | Reply

>
>

9/18/2009 7:16:04 PM#

Microsoft hat bei Vista gute Erfahrung gemacht was passiert wenn man z.B. Sicherheit höher bewertet als Kompatibilität. Deswegen ist es (derzeit) auch völlig richtig am Client noch 32 Bit anzubieten.

Georg BinderAustria | Reply

>
>
>

9/18/2009 7:27:11 PM#

Und warum gab es dann kein Windows 95 in 16 & 32 Bit :-P

wer im Glashaus sitzt...Germany | Reply

>
>
>

9/18/2009 8:54:47 PM#

Die Frage ist doch ganz einfach: Wann ist der Tag gekommen, an dem Kompatibilität, aufgrund sehr gering gewordener Nachfrage nach 32 Bit, für Microsoft ein vernachlässigbarer Faktor wird?
In 3 Jahren? In 6 Jahren? In 10 Jahren?
So lange das jeweils aktuelle Windows 32 Bit unterstützt, so lange werden Firmen auch 32 Bit-Anwendungen nutzen - selbst dann, wenn besagte Anwendungen bereits am Krückstock gehen. Motivation für eine grundsätzliche Modernisierung, kommt so aber gewiss nicht auf. Da heißt es dann weiterwursteln, mit dem was man an "Bewährtem" hat.

Und übrigens, Vista war wohl nicht wegen 64 Bit unterirdisch und dadurch wenig beliebt, sondern wegen dem neuen Treibermodell. Daraus hat man gelernt und bei Vista 2nd Edition,... *räusper*, ich meinte natürlich Windows 7, dieses nicht noch einmal gewechselt bzw. sonst viel verändert, was zu Inkompatibilitäten führen könnte.

Aber egal, bei mir läuft unter Windows 7 64-Bit alles bestens und extrem schnell - naja, bei 12 GB RAM, darf man das aber wohl erwarten Laughing

GMAustria | Reply

>
>
>
>

9/18/2009 9:37:43 PM#

Ich hab auch 12 GB RAM (wenn ich alle verfügbaren Computer zusammenzähle,...)

Angeber! Smile

Georg BinderAustria | Reply

>

1/8/2010 3:35:33 PM#

Weltklasse!!

Danke für den super Tipp....

HiasiAustria | Reply

>

1/21/2010 10:28:33 PM#

Super spitzenklasse!!!!!

taunaGermany | Reply

>

1/24/2010 11:05:13 PM#

supper, danke

ThomasGermany | Reply

>

10/10/2010 1:07:52 AM#

Ich werde das bei uns mal verlinken das ist sehr Interessant das Thema.

wickinger8Germany | Reply

>

12/8/2010 4:38:27 PM#

Scheint mit Adobe Reader X behoben worden zu sein

MartinGermany | Reply

>

2/1/2011 1:15:50 PM#

Nein, mit Acrobat X es wurde nicht behoben, hier fehlt der Eintrag AppID komplett. Musste neu erstellen.

ThomasGermany | Reply

>

9/4/2011 10:09:50 AM#

die manuelle änderung des sehr gut und klar beschriebenen Reg.eintrages hat leider nichts gebracht

Peter WyssSchweiz | Reply

Pingbacks and trackbacks (3)+

>

9/21/2009 8:10:17 AM#

Pingback from blog.lieberlieber.com

WindowsBlog.at | Outlook und Explorer PDF Preview auf 64 Bit | LieberLieber Software TeamBlog

blog.lieberlieber.com | Reply

>

9/21/2009 9:20:17 PM#

Pingback from windows-7-board.de

PDF-Vorschau im Explorer aktivieren - Windows 7

windows-7-board.de | Reply

>

11/13/2011 7:51:03 AM#

Pingback from dims.de

PDF iFilter für 64-bit Plattform | Ingenieurbüro Sauerteig

dims.de | Reply

Add comment

  Country flag

biuquote
Loading

Datenschutzhinweis: Sie stimmen durch "Kommentar speichern" der Speicherung Ihrer Angaben durch Microsoft Österreich für die Beantwortung der Anfrage zu. Sie erhalten dadurch keine unerwünschten Werbezusendungen. Ihre Emailadresse wird auf Ihren Wunsch dazu verwendet Sie über neue Kommentare zu informieren.

Microsoft respektiert den Datenschutz. Datenschutz & Cookies